ecam 23.420 Display keine Anzeige

Diese Seite verwendet Cookies und Google AdSense. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen und Google AdSense zur Einblendung von Werbung benutzen. Weitere Informationen

  • MosesRB schrieb:

    Also ich hab die LCD´s von der neuen und der alten Bedienplatine getauscht und sieh da, wenn das Display nicht geht ist das LCD selbst schuld und nix anderes, und das ist Irreparabel, weil da der Chip auf dem Glas sitzt (COG).Mann kann nur das LCD selbst tauschen.
    Versuche jetzt mit nem vergleichbaren LCD aus China was zu basteln, wenn es den endlich mal da ist und es geklaptt hat poste ich das hier.
    Ich würde das Thema gerne aufwärmen: Hattest du Erfolg/neue Erkenntnisse?
  • robzy schrieb:

    Ich würde das Thema gerne aufwärmen: Hattest du Erfolg/neue Erkenntnisse?
    Hi hi , also viel neues gibt nicht,
    das China Display ist da und liegt seit dem zusammen mit der kaputten BE in nem Karton neben mein Arbeitsplatz und wartet darauf das ich mal Langeweile habe , aber leider sind da auch noch andere Kartons die genauso warten.
    Theoretisch!! sollte es aber gehen , vorausgesetzt dass das neue LCD und das alte LCD auf die gleiche Weise mit dem PIC(Mikrocontroller) kommunizieren(Protokoll),wovon ich eigentlich ausgehe weil beides 20x2 dot-Matrixs Displays mit COG sind. Dann brüchte man lediglich "nur" die Pinbelegung des neuen Displays an die BE anpassen. Wofür ich aber derzeit nicht den nötigen Gehirnschmalz über habe (der Schreibtisch ist voll)!
    Hinzukommt das das neue Display bisschen kleiner und in andere Farbe (also nicht blau) ist, aber damit könnte man leben, denke ich.
    Sobald ich was weiß würde ich es hier Posten.
    Ansonsten bleibt euch nur der Selbstversuch oder ne neue BE Platine, denn ein exakt passendes Display habe ich bis dato noch nicht gefunden.
    Anbei mal ein Bild vom neuen und altem Display. Und an alle die die jetzt meckern würden -> ja, es wäre allerhöchstes eine semiprofessionelle Bastellösung.Aber billiger als eine neue BE
    Bilder
    • IMG_20180323_202800.jpg

      198,9 kB, 675×900, 166 mal angesehen
  • Hallo,
    ich bin unsicher, ob ich mich hier dranhängen kann oder lieber einen neuen Thread aufmachen soll?

    ...ich habe nämlich das geschilderte Problem mit ECAM 23.420 (SW?) seit eben LEIDER AUCH!

    Das Gerät lief bereits und hat mir heute auch schon Kaffee gemacht. Dann habe ich beim Tippen aufs die 1-Tasse-Taste einen gewitscht gekriegt, das Dispülay leuchtete kurz heller auf und bleibt seither schwarz.
    Kaffee kann "blind" gezogen werden...
    Ich habe jetzt gelesen, dass die Platine auch die Bedientasten/Bedienelemente steuert und frage mich, ob das gesamte Teil ausgetauscht werden muss, wenn die Tasten an sich ja noch funktionieren und "nur" das Display schwarz bleibt?? Garantie ist abgelaufen...

    Ich bitte um Nachsicht, bin blond und hab von Technik keine Ahnung.
    Ich habe das Gerät vor Weihnachten gerade für 60 Euronen vom Fachhändler komplett überholen lassen, sprich Dichtungen erneuern und fetten.
    Zuvor war 1 Mal eine winzige Pfütze links aufgefallen, nachdem ich Kaffee ziehen wollte und das Betriebsgeräusch zu hören war, an den Ausgabe aber kein Kaffee herauskam.
    Den Händler hatte ich darauf hingewiesen, da die befürchtete, dass sich irgendwo im Gerät Wasser/Kaffee ansammeln könnte...

    Bin jetzt unsicher, ob ich hier Rücksprache halten soll, ob evtl. die dahinter vermutete Undichtigkeit auch nach der Überholung noch bestanden hat und es dadurch einen Kurzschluss gegeben hat....
    Da das Problem anscheinend ja so selten auftritt, kann es ja nicht unbedingt Altersschwäche sein, oder doch?

    Auf Antworten freue ich mich und bedanke mich schon mal vorab :1f609:
  • Hallo Spanier,
    ... das ist ja SUPER nett. Bin ganz platt über die Hilfsbereitschaft hier!

    Um die Platinennummer herauszufinden, muss ich ja das Gehäuse öffnen und hab mich jetzt TATsächlich daran gewagt.
    Dabei möchte ich nach der Anleitung hier ("Öffnen des Gehäuses Delonghi ECAM 23.450) vorgehene.
    Hinterwand und Seiten sind ab. 2 Schrauben vom "Deckel" gelöst, jetzt wäre die Front dran.
    Kann ich die Heißwasser-Düse einfach abziehen? Ist wahrscheinlich ne blöde Frage, aber in der Beschreibung ist das weder erwähnt noch bebildert. Die ist auf S. 6 dann einfach ab und die Front lässt sich lt Beschreibung entfernen. Bei mir blockiert aber die Düse und der Dampfregler...

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Coboldine ()

  • Hi, Maschinist, Danke!
    Ich hab es jetzt mit nem Video geschafft, vielleicht auch für andere hilfreich, deswegen hier der Link...
    Video Youtube

    Die benutzen für das Lösen der Klammer ein Plastikwerkzeug, was ein Normalo natürlich nicht hat.
    Ich hab mir mit nem Raclette-Schäufelchen aus Holz beholfen, ohne was zu zerkratzen oder zu zerbrechen.

    Die Nummer, die ich ohne weiteres Auseinandernehmen auf der Rüclseite vom Bedienelement auf einem weißen Etikett lese, lautet: 1321 59311 211 068 1081.

    Bei jura-ersatzteile-shop heißt es aber, die Nummer müsste mit 5... anfangen.
    Bin ich also noch nicht weit genug ins Innere vorgedrungen? Heißt, muss ich die 4 kleinen Kreuzschlitz-Schrauben vom Bedienelement auch öffnen?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Coboldine ()

  • So die Pinbelegung fürs Display ist klar (so ziemliche)

    Original Display ist ein TM202SIFSUGWA schwer Infos darüber zu bekommen , aber es sollte ein 20x2 LCD mit ST7036i Controller sein.
    Durchs reverse engineering der Platine kann ich aber sagen das:
    Pin 1: Vo (Kontrast) sein muss da Spannungsteiler zwischen Vdd(+5V) und Vss(-V /GND) eventuell muss man da für nen anderes Display noch die Widerstände(R71,R72) anpassen oder noch besser nen poti.
    Pin 2: Ist NC (not connected)
    Pin 3: Ist Vdd (+5V)
    Pin 4: Ist Vss (GND)
    Pin 5: müsste SDA sein da er 1. mit nem 1kohm pull up am Vdd und 2.über nen 150ohm Schutzwiderstand am pin24 des PIC hängt.
    Pin 6: müsste SCL sein der auch mit 1kohm pull up am Vdd dran ist und und unmittelbar auf den Pin25 am Pic angeschlossen ist.(und da ich am Oszi auch ne Puls habe)
    Pin 7: müsste dann der Reset sein da er unmitelbar am PIN23 vom PIC angeschossen ist.

    Mein Display RX2002a (ebay Stichwort "ST7036i" , Artikelbeschreibung mit einschließen sonst keine Treffer) bzw. ST7036 (Es scheint eventuell zwei Varianten zu geben mit und ohne I²C bin mir aber nicht sicher die ohne i sind billiger )
    Laut Datenblatt:
    Pin 1. Vo
    Pin 2. und Pin3. sind für ne boost up Schaltung also falls man das Display nicht an 5V sondern an 3,3V betreiben möchte und ne Spannungserhöhung braucht, brauchen wir aber nicht da 5V des halb -> NC
    Pin 4. Vdd
    Pin 5. Vss
    Pin 6. SDA
    Pin 7. SCL
    Pin 8. RST

    Somit sollt es also so aus sehen, dass wir die Beinchen 2 und 3 vom neuen LCD weg biegen (ab knipsen) und die restlichen so durch verdrahten. Allerdings bleibt Pin2 auf der Platine Leer nicht vergessen . Hintergrundbeleuchtung habe ich die Alte genommen.
    Theoretisch sollte es so Funktionieren. Getestet hab ich es aber noch nicht , weil ich die Maschine nicht mehr da habe, aber ich werde berichten sobald ich es gemacht habe, ob es geklappt hat.

    So und jetzt gehe ich Pennen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von MosesRB ()

  • Also ich hab bezahlt vor 1,5 Jahren: 14,20€. Gestern hab ich geguckt da gab es noch eins in der bucht für 15€ aus Cottbus , heute kostest es beim gleichen Händler 35€, warum auch immer. Man bekommt aber eins unter 20€ bei einem anderen Händlern oder aliexpress.

    Ich habe es allerdings immer noch nicht getestet!!! Also entweder Risiko eingehen oder noch abwarten.
  • Hallo in die Runde,

    habe leider genau das gleiche Problem bei einer 23.450er :1f622:
    Mit einem I2C-Sniffer ist Datenverkehr auf die Adresse 0x78 zu erkennen --> sollte mit einem 7036i Display funktionieren

    Ich habe daraufhin letzte Woche ein Midas LCD Monochrom-Display MCCOG22005A6W-BNMLWI bestellt und heute ganz erwartungsvoll angeschlossen:






    nix :1f62b:

    Theoretisch könnte man mit einem AVR die Daten vom I2C mitlesen und auf irgendeinem Display ausgeben, die Daten werden vor der Ausgabe über das Display scheinbar an 0xA0 gesendet:




    Gruß
    Jens