ecam 23.420 Display keine Anzeige

Diese Seite verwendet Cookies und Google AdSense. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen und Google AdSense zur Einblendung von Werbung benutzen. Weitere Informationen

  • HD5730_Revidierer schrieb:

    Hallo in die Runde,

    habe leider genau das gleiche Problem bei einer 23.450er :1f622:
    Mit einem I2C-Sniffer ist Datenverkehr auf die Adresse 0x78 zu erkennen --> sollte mit einem 7036i Display funktionieren

    Ich habe daraufhin letzte Woche ein Midas LCD Monochrom-Display MCCOG22005A6W-BNMLWI bestellt und heute ganz erwartungsvoll angeschlossen:






    nix :1f62b:

    Theoretisch könnte man mit einem AVR die Daten vom I2C mitlesen und auf irgendeinem Display ausgeben, die Daten werden vor der Ausgabe über das Display scheinbar an 0xA0 gesendet:




    Gruß
    Jens

    Du.... ,Sorry erstmal für die späte Antwort,
    Wie ich das so im 2.Bild von dir sehe hast du das Display meiner Meinung nach nicht ganz korrekt angeschossen. Pin1 (also Loch1) ist Vo ,das ist der Spannungsteiler für den Kontrast und Loch3 ist die Versorgungsspannung Vdd die bei dir aber nicht angeschossen ist , bzw du hast Vdd vom Display gebrückt und mit an Vo angeschlossen , glaub aber nicht dass das so funktioniert. So wie ich das Datenblatt verstehe kann man zwar Vo mit Vdd Brücken um den Kontrast hardwaremäßig auf 100% zu stellen , man sollte es dann aber trotzdem an die +5V anschließen. Das wollte ich übrigens auch mal ausprobieren und hab dazu R72 ab gelötet (R72 negative Masche;R71 positive Masche des Spannungsteilers,liegen genau unterm Display nähe pin1&2) aber leider ist mir da ein kleines (dummes) Missgeschick passiert ->das Netzteil stand noch auf 15V als ich es eingeschaltet habe (und ich habe da auch noch vorher kurz dran gedacht ) zwar war es auf 300mA limitiert aber Trotzdem ist der EEprom (U7) in Rauch aufgegangen.Zum Glück habe ich von allem vorher Dumps gemacht. Muss nachher auch mal gucken ob ich ein 256K eeprom habe und ob der Pic noch Lebt und oder ob ich ein neuen brauche und und und (LCD;U7 Uhr)

    Des weiteren frage ich mich ob mein LCD überhaupt I²c kann weil der Händler bietet zwei Varianten an einmal ST7036 (17€) und ST7036i 34€ was mit zu denken gibt.

    Dann Frage ich mich auch ob eventuell der Rest beim Originalen Display TM202SIFSUGWA vielleicht negiert war(gibt's auch) und wir deswegen kein Bild haben weil unser es nicht ist, ich meine es liegt doch dauerhaft ein High Pegel auf Loch7 (reset) an,ist doch richtig oder ? Bin leider nicht mehr dazu gekommen es mit dem Oszi zu prüfen. Wollte auch mal gucken ob man da was decodieren kann.

    Schön wäre es wenn man mehr übers original Display wüste, hab im Netz lediglich nur diesen Beitrag gefunden wo jemand vergebens versucht so eins in betrieb zu nehmen.
    Bilder
    • IMG_20190205_191856[1].jpg

      232,12 kB, 1.440×810, 20 mal angesehen

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von MosesRB ()

  • Viel gelesen, viel rumprobiert-> noch nix erreicht.

    Vermute mal, dass die/der DeLonghi Programmierer damals sich den Spaß erlaubt haben die standard Adresse des Displays zu ändern , um die Leute zu ärgern, oder es ist einfach eine sonder sonder Anfertigung und deshalb finden wir auch kein Datenblatt dazu.
    (übrigens die Firma Tianma ,die höchstwahrscheinlich das original Display hergestellt hat , hat nen Sitz in Düsseldorf was von mir aus gesehen 20 Minuten mit dem Auto wär, aber ich wollte mich da nicht unbedingt blamieren und fragen, da man wahrscheinlich erst 100.000stk. abnehmen müsste bevor die einen da ernst nehmen . Aber wer will kann da ja mal anrufen und sich schlau machen)

    So wie ich das verstehe, könnten , sollte , müsste man die ST7036i Displays erst für und über i²c initialisieren ,dafür bin ich aber (noch) zu blöd. Beschreibung wie steht im ST7036i PDF

    (einer weiter Verschwörungstheorie von mir ist: dass das Original Display gar nicht kaputt ist, sondern nur durch den Hochspannungsüberschlag der eeprom es Displays mit der Adressierung gelöscht wurde , und man das Display lediglich neu Initialisieren muss, wer weis wer weis)




    Übrigens:

    Bits: 7
    As Binary: 0111100
    As Equation: 32 + 16 + 8 + 4
    As Decimal: 60
    As Hexadecimal: 3C


    Wird meiner Meinung nach aber auch vom MCU angesprochen (W:3C 80 80 ,W:3C 40 20 usw.) berichtigt mich bitte wenn ich da falsch liege (weil ich habe kein Ahnung und davon ganz viel, fange gerade erst an mit Programmieren)
    W: heist doch-> Write ,danach Adresse:3C, und dann die Daten 80 80.
    Es ist ein ganz schön dickes Pakte was für mich nach Display Daten riecht, aber die gesendeten Daten wiederholen sich ziemlich oft 40 20 40 20 dann mal zwischendurch mal 80 80 dann wieder 40 20 , es kommt aber trotzdem kein Bild.
    Oder ist das ein vergeblicher versuch der MCU das Display zu Adressieren.





    HD5730_Revidierer schrieb:

    Mit einem I2C-Sniffer ist Datenverkehr auf die Adresse 0x78 zu erkennen --> sollte mit einem 7036i Display funktionieren
    @HD5730_Revidierer wie Kommst du den auf die 0x78??



    Ich habe außerdem auch noch 3 kurze hintereinander folgende W:68 anfragen dann aber wieder den dicken W:3C Brocken


    Hab noch über eine Möglichkeit gelesen wie man mittels Arduion die Tatsächliche Adresse eines I²C Bausteines Scannen kann. Dies werde ich mal auch ausprobieren und dann mal berichten . Zum gelesenen Artikel geht es hier .

    In dem Artikel wir auch ferner beschrieben ,dass man prinzipiell jedes beliebig Display nehmen kann und es mittels PCF8574(A) Portexpanders am I²c bus betreiben kann und da so gut wie alle Dotmatrix Text LCD's auf die gleiche Art und Weise funktionieren (Stichwort ST7066 kompatibel), müsste ich auch mit meinem 16x2 Arduino starterkit Display ne Anzeige bekommen, zwar eventuell abgehackt oder verschoben aber ne Anzeige.
    Und der Vorteil an diesem PCF8574 / PCF8574A Expnader ist, dass man ihn Hardwaremäßig , sprich durch setzten von Lötbrücken, die Adresse ändern kann. Insgesamt 16 Möglichkeiten gibt es.
    Der PCF8574 (in Deutschland erhältlich) Adressbereich von 0x20 bis 0x27
    Und der PCF8574A (muss ich aus China kommen lassen) Adressbereich 0x38 bis 0x3F (dies würde mit dem Adressbereich aus dem ST7036i Datenblatt zusammenpassen)


    Und da ich den Driss aus kosten gründen komplett aus China bestellen werde , erwartet frühestens Ergebnisse in 4 Wochen.

    Dieser Beitrag wurde bereits 15 mal editiert, zuletzt von MosesRB ()

  • Naja unsere Maschine in der Firma war ja kaputt , bei der habe ich die ganze Bedieneinheit getauscht für ca.70€ oder so, kurz darauf hat der Chef ne neue gekauft.
    Die Maschine von Nachbar meiner Eltern hat auch den gleichen Fehler.
    Die Maschine von einem Kumpel hat letzte Woche auch den Geist aufgegeben , kurz nach dem ich es dem prophezeit habe.
    Mein Schwager berichtet mir auch von einem, Arbeitskollegen dem das gleiche passiert ist und dass ein anderer Arbeistkollege auch so ne Maschine hat die aber noch funktioniert(aber wahrscheinlich auch bald blind ist).

    Also ich denke , wenn man da ne kostengünstigere Lösung findet als immer die Bedienplatine zu wechseln wäre das interessant, zumal es nicht so einfach ist immer die passende Platine für sein gerät zu finden.
    Ausredendem hasse ich geplante Obsolenz
  • Ich frage mich echt ernsthaft, warum bei Delonghi, die mit Abstand die Besten KVAs überhaupt bauen, die LCD Displays über Generationen hinaus, ein Dauerthema ist. Bei den ESAM 6700 haben die 3 Maschinen-Generationen gebraucht bis es keine Displays mehr ausfielen (6700 EX:3). Dann die 23.XXX bei der die Reihenweise ausfallen, nach dem man vorher nen Pulli ausgezogen oder die Katze gestreichelt hat. Diese Dauerlöterei an den Displays nervt langsam.
  • Das kannst du in so vielen Bereichen sehen, das hat nicht nur mit DeLonghi zu tun.
    Umso mehr Technik umso mehr Probleme. Die meisten sehen das doch bei ihrem eigenen Auto.
    Auch Autos haben Pixelfehler im Tacho zum Beispiel, je nachdem welche Technik verwendet wurde für die Anzeigen.

    Bei dem ecam 23.450 ist ein COG Display verwendet, der Chip sitzt im Glas.
    Mangelnder ESD Schutz, und das wars. Das fällt bei diesem Modell auf.
    Deswegen habe ich auch gefragt wie viele Layer das neue Modul hat.
    Normal wird dieses in 2 Layer produziert.
    DeLonghi verwendet 4 Layer, wegen dem Kontrast.
    Ich kann bei Platinen und Displayfehlern helfen.
    Werbung
  • SpanierHH schrieb:

    Was hast du für das Display Modul bezahlt?
    Hi SpanierHH, sorry für die späte Antwort, bin normalerweise hier nicht aktiv.
    Das Display hat gekostet 57,90, Versand kostenlos.

    _______________
    Das Gerät hat seit dem Displaywechsel gut funktioniert. Eben habe ich wieder einen gefitscht gekriegt und das Display schien wieder hin... **HEUL**
    Fluchend habe ich die Maschine über den hinteren Hauptschalter ausgestellt, nach 2 Stunden wieder an und jetzt geht das Display wieder.
    Mir ist das nicht geheuer.
    Ich will ncht noch mehr Geld nachwerfen, zumal Ich sie noch kurz vor Weihnachten beim Fachhändler zur Inspektion hatte (Dichtungen bewegliche Teil fetten) und das Gerät aus 2012 ist.

    ??? Was kann das bloß sein? Ich hab seit neuestem so gemütliche Gummilatschen, kann es sein, dass ich mich damit auflade? Dagegen spricht, dass es an keinem anderen Gerät passiert...
    Was mir auffällt und auch vor dem ersten Display-Defekt schon passierte: Ich will einen Kaffee ziehen, höre die normalen Betriebsgeräusche, es kommt aber kein Kaffee raus.
    D.h. akustisch normaler Betrieb, aber kein Kaffee in der Tasse. Ich frage mich, wo landet die Flüssigkeit, denn Pumpe etc arbeiten ja hörbar???
  • SpanierHH schrieb:

    Wie viele Layer hat dein neues Modul?
    Layer?? Was meinst du damit?? Meins ist ein Standard STN Display mit Hintergrundbeleuchtung somit müsste es ein Transflektives sein und hat demnach 5 Schichten (Layer).

    SpanierHH schrieb:

    Ich kann bei Platinen und Displayfehlern helfen.
    Weist du die I²C Adresse von dem Display , und oder hast Infos wo man ein brauchbares ersatz LCD Display her bekommt? Jedes mal die Bedienplatine wechseln wenn LCD aussetzt finde ich blöd, zumal es auch ins Geld geht.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von MosesRB ()

  • Layer, die Anzahl an Schichten. Wenn du von der Seite in das Display schaust, siehst du bei dem ecam 23.420 Display 4 Schichten, oder?
    Die normal verwendeten COG Module haben 2 schichten polarisierendes Glas und dahinter die Hintergrundbeleuchtung wenn ich das richtig sehe.

    Du kannst sniffer nutzen um die Adtresse auszulesen. Aber wofür willst du das? Willst du bestimmte Dinge auf dem Display anzeigen?

    Ich hoffe hier regen sich noch ein paar um diese Display auf, dann suche ich gerne eine Lösung :1f609:
    Ob das viel günstiger wird als originale mag ich zwar bezweifeln, aber bessere Qualität geht sicher.
    Ich kann bei Platinen und Displayfehlern helfen.