ESAM4500: Leistungsplatine reparieren?

Diese Seite verwendet Cookies und Google AdSense. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen und Google AdSense zur Einblendung von Werbung benutzen. Weitere Informationen

  • Hey Roland =)

    Danke für deine Mühen hier einigen beim retten der Platinen zu helfen.

    Ich teste mich gerade auch an das Thema heran, stoße aktuell aber auf ein Problem.
    Zum herumspielen habe ich mir eine ESAM 6700 Ex1 Platine genommen. Auslesen scheint zu funktionieren, aber schreiben und auch leermachen nicht. Muss man da was beachten?

    Co Delonghi 5213212471
    Bilder
    • Unbenannt.png

      293 kB, 672×826, 135 mal angesehen
    Werbung
  • Cables seemed to be fine. The Configuration of the dumped hex-file was set to all protect. No Idea why.

    But in case that someone has the same problem, here is a workaround:



    In this image You see that the protection is not editable.



    Open the Config Word editor and set all editable numbers on Config 5 300008 to 1 and hit save.



    After this, You can deactivate the protection again before flashing.
  • Liebe Leute,

    eure Einträge sind schon ein paar Tage her, aber ich hoffe ihr seit noch da :1f609:
    Ich habe ein ähnliches Problem:
    Die Maschine hat(te) ein mechanisches Problem. Die Mutter an der Spindel war gelöst. Ich vermute das hat zur Störung geführt.
    Mir ist es nicht gelungen einen Reset durch Knöpfedrücken und Netzsteckerziehen zu erzielen.
    Daher denke ich auch hier müsste der EPROM mal zurück gesetzt werden. Aber ich bin hier unsicher:
    Daten:
    Maschine: ECAM24.210.SB
    Kontroller: PIC18LF2520-I/SO
    Datenstecker?: J13 mit 8 Pins
    Kann mir jemand erklären den EPROM zurück zu setzten, helfen die Pinbelgung richtig zu machen?
    Ich würde mir dann so ein Pickit kaufen (oder falls einer seins los werden will auch jemandem abkaufen) und es versuchen.
    Ist die nötige Software dann bei dem Kit bei, oder was muss man runter laden.

    Besten Dank!
    René
    Bilder
    • IMG_20210424_103117.jpg

      255,48 kB, 1.200×900, 118 mal angesehen
    • IMG_20210424_103133.jpg

      296,62 kB, 1.200×900, 93 mal angesehen
    • IMG_20210424_121339.jpg

      271,75 kB, 1.200×900, 80 mal angesehen
  • Esam 3000 B: nach Einschalten leuchten im Wechsel 4 Kontolllampen

    Im Beitrag 33 von mir habe ich es erklärt. Ist zwar eine andere Maschine, das Prinzip ist aber das gleiche.
    Software ist nicht dabei, sollte es im Netz geben. Wenn nicht, melden.
    Lange Kaffeespaß mit Delonghi = Brühgruppe + Antrieb regelmäßig schmieren + entkalken mit Amidosulfonsäure :1f44d:
    ESAM 3.120S EX.1 (BJ 12/2015) im Büro Stand 05.03.2022 = 57200 Bezüge. :1f44d:
  • hhb schrieb:

    Liebe Leute,

    eure Einträge sind schon ein paar Tage her, aber ich hoffe ihr seit noch da :1f609:
    Ich habe ein ähnliches Problem:
    Die Maschine hat(te) ein mechanisches Problem. Die Mutter an der Spindel war gelöst. Ich vermute das hat zur Störung geführt.
    Mir ist es nicht gelungen einen Reset durch Knöpfedrücken und Netzsteckerziehen zu erzielen.
    Daher denke ich auch hier müsste der EPROM mal zurück gesetzt werden. Aber ich bin hier unsicher:
    Daten:
    Maschine: ECAM24.210.SB
    Kontroller: PIC18LF2520-I/SO
    Datenstecker?: J13 mit 8 Pins
    Kann mir jemand erklären den EPROM zurück zu setzten, helfen die Pinbelgung richtig zu machen?
    Ich würde mir dann so ein Pickit kaufen (oder falls einer seins los werden will auch jemandem abkaufen) und es versuchen.
    Ist die nötige Software dann bei dem Kit bei, oder was muss man runter laden.

    Besten Dank!
    René


    Wenn der Reset nicht funktioniert, empfehle ich eine neue Platine. Es kostet 30 Euro nagelneu! Wenn Sie mit PICkit nicht vertraut sind und noch keines haben, lohnt sich die Mühe nicht
    kaffeevollautomaten für ein zusätzliches einkommen reparieren.
    -------------------------------------------------------------------------------------------
    ---------------------------Gegen Elektroschrott :1f621: . Wir ersetzen nicht! wir reparieren! :1f609: --------------------------------
    -------------------------------------------------------------------------------------------
    Entschuldigung für Grammatikfehler, ich spreche kein Deutsch und benutze Google Übersetzer, :1f622:
  • @OLLIFFM: Das hat leider nicht funktioniert. Es leuchtet immer wieder das rote Dreieck mit dem Ausrufezeichen. Ich habe echt schon viele Tastenkombinationen probiert. Aber wer noch kreative Ideen hat, her damit.

    @georgts: Danke für den Hinweis. Jetzt habe ich mir so ein Pickit leider schon bestellt. Versuch macht gluch ("klug" für die nicht-Mutterspracher). Wenn nicht komme ich auf Ihren Vorschlag zurück.

    Ich kann mir auch nicht so richtig vorstellen,dass die Platine kaputt ist. Die Maschine ist mit lautem Krachen und Knirschen ausgegangen. Das lässt mich vermuten, dass ein mechanischer Fehler die Ursache war und die Elektronik dann ein Fehle gegangen ist.
  • Nein, es ist nicht. Ich habe kürzlich einen neu programmiert

    hhb schrieb:

    @OLLIFFM: Das hat leider nicht funktioniert. Es leuchtet immer wieder das rote Dreieck mit dem Ausrufezeichen. Ich habe echt schon viele Tastenkombinationen probiert. Aber wer noch kreative Ideen hat, her damit.

    @georgts: Danke für den Hinweis. Jetzt habe ich mir so ein Pickit leider schon bestellt. Versuch macht gluch ("klug" für die nicht-Mutterspracher). Wenn nicht komme ich auf Ihren Vorschlag zurück.

    Ich kann mir auch nicht so richtig vorstellen,dass die Platine kaputt ist. Die Maschine ist mit lautem Krachen und Knirschen ausgegangen. Das lässt mich vermuten, dass ein mechanischer Fehler die Ursache war und die Elektronik dann ein Fehle gegangen ist.
    kaffeevollautomaten für ein zusätzliches einkommen reparieren.
    -------------------------------------------------------------------------------------------
    ---------------------------Gegen Elektroschrott :1f621: . Wir ersetzen nicht! wir reparieren! :1f609: --------------------------------
    -------------------------------------------------------------------------------------------
    Entschuldigung für Grammatikfehler, ich spreche kein Deutsch und benutze Google Übersetzer, :1f622:
  • mach das nicht kompliziert. Es ist einfach. Wenn Sie das Relais hören und es sich nicht bewegt, liegt kein Programmierproblem vor. Wenn Sie es nicht hören und sofort einen allgemeinen Fehler haben, muss dieser neu programmiert werden.Temperatursensoren und obere MS müssen ebenfalls überprüft werden
    kaffeevollautomaten für ein zusätzliches einkommen reparieren.
    -------------------------------------------------------------------------------------------
    ---------------------------Gegen Elektroschrott :1f621: . Wir ersetzen nicht! wir reparieren! :1f609: --------------------------------
    -------------------------------------------------------------------------------------------
    Entschuldigung für Grammatikfehler, ich spreche kein Deutsch und benutze Google Übersetzer, :1f622:
  • Hallo liebe Leute, hier ein kurzer Statusbericht:
    - PicKit 3 durch Löten von Kabel an den Pads angeschlossen
    - MPLAB IPE auf Mac und den PickKitProgramierer auf Windows mit allen möglichen Einstellungen (ext. Stromversorung, Versorgung durch PicKit mit verschiedenen Spannungen, neue Firmware auf PicKit geladen usw.) gestartet
    - immer wieder "Connection Failour", hier schient was defekt zu sein, das habe ich dann aufgegeben :2639:
    - neue Platine bestellt (35€+5€)
    - Brühgruppenantrieb wieder ordentlich eingesetzt (hier war die Mutter oben gelöst) und auf die untere Sensorposition gefahren, Abtropfschale u Wassertank eingesetzt
    - Maschine hat mit Erstinbetriebnahme begonnen und scheint zu tuten was sie soll
    - Problem jetzt: Heizung geht nicht an, die Thermosicherungen haben keinen Durchgang (warum auch immer, vorher ging es)
    - habe jetzt neue 192C Thermoss. bestellt....
    stay tuned
  • hhb schrieb:

    Hallo liebe Leute, hier ein kurzer Statusbericht:
    - PicKit 3 durch Löten von Kabel an den Pads angeschlossen
    - MPLAB IPE auf Mac und den PickKitProgramierer auf Windows mit allen möglichen Einstellungen (ext. Stromversorung, Versorgung durch PicKit mit verschiedenen Spannungen, neue Firmware auf PicKit geladen usw.) gestartet
    - immer wieder "Connection Failour", hier schient was defekt zu sein, das habe ich dann aufgegeben :2639:
    - neue Platine bestellt (35€+5€)
    - Brühgruppenantrieb wieder ordentlich eingesetzt (hier war die Mutter oben gelöst) und auf die untere Sensorposition gefahren, Abtropfschale u Wassertank eingesetzt
    - Maschine hat mit Erstinbetriebnahme begonnen und scheint zu tuten was sie soll
    - Problem jetzt: Heizung geht nicht an, die Thermosicherungen haben keinen Durchgang (warum auch immer, vorher ging es)
    - habe jetzt neue 192C Thermoss. bestellt....
    stay tuned
    :1f60f: Es war zu 90% sicher, dass es so enden wird
    kaffeevollautomaten für ein zusätzliches einkommen reparieren.
    -------------------------------------------------------------------------------------------
    ---------------------------Gegen Elektroschrott :1f621: . Wir ersetzen nicht! wir reparieren! :1f609: --------------------------------
    -------------------------------------------------------------------------------------------
    Entschuldigung für Grammatikfehler, ich spreche kein Deutsch und benutze Google Übersetzer, :1f622:
  • Leute, ich verzweifle gleich.
    Die neuen Thermosicherungen sind drinen, die Maschine geht normal an, heizt, spült und zeigt Betriebsbereitschaft an (Kaffeetasse leuchtet, Bohne leuchtet und das E leuchtet). Ich drücke auf "eine Tasse" um einen Kaffee zuzubereiten: Brühgruppe fährt irgenwie, aber kein Mahlwerk geht (obwohl sich das im Testmodus dreht) und es kommt kein Kaffee.
    Hat jemand eine Idee?
  • hhb schrieb:

    Leute, ich verzweifle gleich.
    Die neuen Thermosicherungen sind drinen, die Maschine geht normal an, heizt, spült und zeigt Betriebsbereitschaft an (Kaffeetasse leuchtet, Bohne leuchtet und das E leuchtet). Ich drücke auf "eine Tasse" um einen Kaffee zuzubereiten: Brühgruppe fährt irgenwie, aber kein Mahlwerk geht (obwohl sich das im Testmodus dreht) und es kommt kein Kaffee.
    Hat jemand eine Idee?


    hatte genau das gleiche Problem mit einer 3000b ex1 (kleine Platine) und Neuprogrammierung löste das Problem. Obwohl ich denke, ist nicht Ihr Fall, weil die Platine brandneu ist
    kaffeevollautomaten für ein zusätzliches einkommen reparieren.
    -------------------------------------------------------------------------------------------
    ---------------------------Gegen Elektroschrott :1f621: . Wir ersetzen nicht! wir reparieren! :1f609: --------------------------------
    -------------------------------------------------------------------------------------------
    Entschuldigung für Grammatikfehler, ich spreche kein Deutsch und benutze Google Übersetzer, :1f622:
    Werbung