Reparatur von Displayfehlern ESAM 6700

Diese Seite verwendet Cookies und Google AdSense. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen und Google AdSense zur Einblendung von Werbung benutzen. Weitere Informationen

  • Reparatur von Displayfehlern ESAM 6700

    Hallo, :opinion:

    pünktlich nach Garantieablauf (zwei Wochen über die 3 Jahre Garantie), sind im Display meiner ESAM 6700 mehrere Zeilen und Spalten ausgefallen. Vertragspartner "Elektro Franke aus Berlin" lehnt eine Kulanzreparatur wegen Garantieüberschreitung ab.

    Weit über 200,00 EUR für ein Ersatzteil sind ziemlich happig. Also erst einmal selbst nachgesehen (bin Elektroniker).

    Die Ursache für die zunehmenden Displayfehler sind meines Erachtens in der Pumpe zu finden. Durch den in der Pumpe arbeitenden Stößel entstehen starke Vibrationen, welche die Lötstellen des Displays ständig durchschütteln und dadurch brüchig werden lassen. Durch oxydation des gelösten Anschlusses im Lötpunkt, kommt es dann zum Ausfall von Zeilen oder Spalten in der Matrix (ähnlich kalten Lötstellen). Mit bloßem Auge ist an den Lötstellen nichts zu sehen. Durch nachlöten aller Display-Lötpunkte sind nun alle Displayfehler beseitigt! Alles in allem eine Stunde Arbeit. Wichtig ist ein fachgerechtes Löten mit einem guten Elektronik-Lot und einem geeigneten Flußmittel. Im besten Fall mit einer Lötstation löten! Das originale-Lot fließt sehr schlecht! Unter Umständen Lot absaugen, Pins mit Glasradierer vom Oxyd befreien und mit gutem Lot neu verlöten.

    :1f393: Vorsicht beim trennen von Display-Platine und Gehäusefront. Das Display ist mit der Glasscheibe des Bedienteils über eine flexible Leiterbahn verbunden, die erst durch öffnen der Steckfassung getrennt werden muss. Bei unvorsichtigen Vorgehen könnte die Leiterbahn abgerissen werden!
    Bilder
    • Fehlerschema.JPG

      44,64 kB, 700×611, 744 mal angesehen
    • Nachlöten.JPG

      106,04 kB, 1.021×602, 1.441 mal angesehen
    • Zerlegt.jpg

      90,84 kB, 1.029×656, 961 mal angesehen
    Werbung
  • Ich habe jetzt 2 Displays nachgelötet inkl. altes Lot absaugen, hat leider nix gebracht.
    Gruß Stefan
    ------------------------------------------------------------------------------------------------------------------------------------------------
    Wo ist das Problem, bei Anfragen Groß-und Kleinschreibung/Punkt und Komma zu beachten? So was fällt bei mir unter Höflichkeit.
    Ich beantworte keine Fragen per PN oder Email, dazu gibt es das Forum!
  • Hallo Stefan,

    natürlich kann auch ein Fehler im Displaytreiber-IC oder der Beschaltung auftreten. Der von mir beschriebene "Wackelkontakt" ist nur eine Fehlermöglichkeit von vielen. Es ist halt nur sinnvoll, erst einmal die Lötstellen nachzulöten um zumindest diese Fehlerquelle auszuschließen.

    Ein Indiz auf einen solchen Kontaktfehler ist, wenn Zeilen oder Spalten mal gehen und mal nicht. Es ist hilfreich ein Foto zu machen oder die fehlerhaften Matrixteile zu skizzieren. Wenn man das Display einige Tage beobachtet ist zu sehen, ob sich die betroffenen Stellen verändern, was auf einen "Wackelkontakt" schließen lässt.

    Bei mir war es der Fehler, da nach dem Löten alles wieder OK war. Einen Versuch ist das allemal wert.

    Hier noch Links mit Display-Infos. Vielleicht hilft ja einer der Tipps bei der Reperatur... :1f642:

    sprut.de/electronic/lcd/

    mikrocontroller.net/articles/AVR-Tutorial:_LCD

    Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von Kaffecarn ()

  • Kaffecarn schrieb:

    Es ist halt nur sinnvoll, erst einmal die Lötstellen nachzulöten um zumindest diese Fehlerquelle auszuschließen.

    Stimme ich dir voll zu. Es gibt ja noch ein Forumsmitglied, der seine Platine nachlötet. Vielleicht hat der mehr Glück.
    Gruß Stefan
    ------------------------------------------------------------------------------------------------------------------------------------------------
    Wo ist das Problem, bei Anfragen Groß-und Kleinschreibung/Punkt und Komma zu beachten? So was fällt bei mir unter Höflichkeit.
    Ich beantworte keine Fragen per PN oder Email, dazu gibt es das Forum!